const regex = /^(?<ALL>(?!.*H-\d{4}\b).*|.*?(?:(?<ID>H-\d{4})\b).*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<ALL>(?!.*H-\\d{4}\\b).*|.*?(?:(?<ID>H-\\d{4})\\b).*)$', 'gm')
const str = `Sample line with H-5722 id
Sample line without id`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}