re = /^(?<ALL>(?!.*H-\d{4}\b).*|.*?(?:(?<ID>H-\d{4})\b).*)$/m
str = 'Sample line with H-5722 id
Sample line without id'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end