#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<!--(.|\s)*?-->"
Local $sString = "<p>teste<p>" & @CRLF & _
"<!-- <!-- comentário mal formado ->---"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)