package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<!--(.|\s)*?-->`)
var str = `<p>teste<p>
<!-- <!-- comentário mal formado ->---`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}