#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<operating_pressure>H)(?P<sep_1>-)(?P<number_of_main_ports>4)(?P<unit_type>W)(?P<actuation_type>EH|H)(?P<unit_size>82)(?P<spool_feedback_main_stage>H|)(?P<spool_symbol>C|D|K|Z|E|F|G|H|J|L|M|Q|R|S|T|U|V|W)(?P<unit_series>3X)(?P<mounting_type>F|)(?P<sep_2>/)(?P<spool_feedback>OF|O|)(?P<pilot_valve>10)(?P<type_of_solenoid>A|L)(?P<solenoid_in_ac_or_dc_version>G|W)(?P<voltage_of_solenoid>220|195|180|127|120|110|96|60|42|24|12)(?P<voltage_rectifier>R|-|)(?P<manual_override_unit>N|)(?P<spool_position_monitoring>Y|)(?P<control_volume_flow>)(?P<unit_for_time_adjustment>S2|S|)(?P<electrical_connection>Z5L|Z2L|Z1L|DKL|DZL|DL|DZ|DK|ZL|KL|Z5|Z4|Z2|Z1|D|L|Z|K|)(?P<sep_3>/)(?P<additional_equipment>17|16|15|14|13|12|11|10|)(?P<orifice_positon>B|)(?P<orifice_diameter>15|12|11|10|08|)(?P<pressure_reducing_valve>D1|)(?P<seal_material>V|)(?P<additional_details>)$" & @CRLF & _
""
Local $sString = "H-4WEH82HD3XF/10CG24N9SK4" & @CRLF & _
"H-4WEH82HE3X/10EG24N9SK4" & @CRLF & _
"H-4WEH82HG3XF/10CW110N9DAL/V" & @CRLF & _
"H-4WEH82HF3XF/10CG24N9S2K4" & @CRLF & _
"H-4WEH82HL3X/10CG24N9S2K4" & @CRLF & _
"H-4WEH82HG3XF/10CW230RNSDL/13" & @CRLF & _
"H-4WEH82HJ3XF/10CG24N9K4" & @CRLF & _
"H-4WEH82E3X/10CG24N9K4" & @CRLF & _
"H-4WEH82HG3XF/10EG24N9SK4/B12" & @CRLF & _
"H-4WEH82HM3XF/10CW110N9" & @CRLF & _
"H-4WEH82HJ3X/10CG24N9ETK4/B10D2" & @CRLF & _
"H-4WEH82HE3X/16AG24NSZ5LQ0G24SO38" & @CRLF & _
"H-4WEH82HE3XF/10CG24N9SDZ/13SO6" & @CRLF & _
"H-4WEH82HE3X/16AG24NZ5LSO8" & @CRLF & _
"H-4WEH82HC3X/10CG24N9S" & @CRLF & _
"H-4WEH82HE3X/10EG24N9K4" & @CRLF & _
"H-4WEH82E3X/10CG24N9SK4QMABG24" & @CRLF & _
"H-4WEH82HE3X/10CG24N9S2" & @CRLF & _
"H-4WEH82HC3X/10CW110N9S2DAL" & @CRLF & _
"H-4WEH82HM3XF/10CW110N9K4" & @CRLF & _
"H-4WEH82HE3XF/10CG60NS2DKL" & @CRLF & _
"H-4WEH82HE3XF/U" & @CRLF & _
"H-4WEH82HD3XF/10CG60NS2DKL" & @CRLF & _
"H-4WEH82HE3X/10CG24N9SK4" & @CRLF & _
"H-4WEH82HM3XF/10CG24N9S" & @CRLF & _
"H-4WEH82HD3X/OF10CG220N9K4" & @CRLF & _
"H-4WEH82HE3XF/10CW230N9TDKL" & @CRLF & _
"H-4WEH82HE3XF/10CG24NSDZ/13SO6" & @CRLF & _
"H-4WEH82HE3XF/10CG24N9SDL" & @CRLF & _
"H-4WEH82HE3X/10CG24N9ESDKL/B10D2" & @CRLF & _
"H-4WEH82HE3X/10CG24N9Z5L" & @CRLF & _
"H-4WEH82HE3X/10CG24N9K4" & @CRLF & _
"H-4WEH82HC3XF/10CG24N9K4" & @CRLF & _
"H-4WEH82HJ3XF/10CW110N9DAL/V" & @CRLF & _
"H-4WEH82HJ3X/10CG24N9S2K4" & @CRLF & _
"H-4WEH82HE3XF/10CG24N9SK4/13" & @CRLF & _
"H-4WEH82HE3X/10CG24N9SZ5L" & @CRLF & _
"H-4WEH82HC3XF/10CG24N9S/13" & @CRLF & _
"H-4WEH82HE3X/16AG24NS2Z5L/13SO35" & @CRLF & _
"H-4WEH82HE3X/10CG24NSDZL" & @CRLF & _
"H-4WEH82HE3XF/10CG24N9S/13" & @CRLF & _
"H-4WEH82HJ3X/10CG24NSDZL" & @CRLF & _
"H-4WEH82HD3XF/OF10EG220N9SK4" & @CRLF & _
"H-4WEH82HD3XF/10CG24N9S2K4/42B10" & @CRLF & _
"H-4WEH82HE3XF/10CG24N9K4" & @CRLF & _
"H-4WEH82HE3XF/10CG24NDLSO847" & @CRLF & _
"H-4WEH82HD3XF/10CG24N9K4" & @CRLF & _
"H-4WEH82HD3XF/OF10CG220N9SK4" & @CRLF & _
"H-4WH82HG3XF/" & @CRLF & _
"H-4WEH82HF3XF/10CW220N9S2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")