import re
regex = re.compile((r"^(?P<operating_pressure>H)(?P<sep_1>-)(?P<number_of_main_ports>4)(?P<unit_type>W)(?P<actuation_type>EH|H)(?P<unit_size>82)(?P<spool_feedback_main_stage>H|)(?P<spool_symbol>C|D|K|Z|E|F|G|H|J|L|M|Q|R|S|T|U|V|W)(?P<unit_series>3X)(?P<mounting_type>F|)(?P<sep_2>/)(?P<spool_feedback>OF|O|)(?P<pilot_valve>10)(?P<type_of_solenoid>A|L)(?P<solenoid_in_ac_or_dc_version>G|W)(?P<voltage_of_solenoid>220|195|180|127|120|110|96|60|42|24|12)(?P<voltage_rectifier>R|-|)(?P<manual_override_unit>N|)(?P<spool_position_monitoring>Y|)(?P<control_volume_flow>)(?P<unit_for_time_adjustment>S2|S|)(?P<electrical_connection>Z5L|Z2L|Z1L|DKL|DZL|DL|DZ|DK|ZL|KL|Z5|Z4|Z2|Z1|D|L|Z|K|)(?P<sep_3>/)(?P<additional_equipment>17|16|15|14|13|12|11|10|)(?P<orifice_positon>B|)(?P<orifice_diameter>15|12|11|10|08|)(?P<pressure_reducing_valve>D1|)(?P<seal_material>V|)(?P<additional_details>)$\n"), flags=re.MULTILINE)
test_str = ("H-4WEH82HD3XF/10CG24N9SK4\n"
"H-4WEH82HE3X/10EG24N9SK4\n"
"H-4WEH82HG3XF/10CW110N9DAL/V\n"
"H-4WEH82HF3XF/10CG24N9S2K4\n"
"H-4WEH82HL3X/10CG24N9S2K4\n"
"H-4WEH82HG3XF/10CW230RNSDL/13\n"
"H-4WEH82HJ3XF/10CG24N9K4\n"
"H-4WEH82E3X/10CG24N9K4\n"
"H-4WEH82HG3XF/10EG24N9SK4/B12\n"
"H-4WEH82HM3XF/10CW110N9\n"
"H-4WEH82HJ3X/10CG24N9ETK4/B10D2\n"
"H-4WEH82HE3X/16AG24NSZ5LQ0G24SO38\n"
"H-4WEH82HE3XF/10CG24N9SDZ/13SO6\n"
"H-4WEH82HE3X/16AG24NZ5LSO8\n"
"H-4WEH82HC3X/10CG24N9S\n"
"H-4WEH82HE3X/10EG24N9K4\n"
"H-4WEH82E3X/10CG24N9SK4QMABG24\n"
"H-4WEH82HE3X/10CG24N9S2\n"
"H-4WEH82HC3X/10CW110N9S2DAL\n"
"H-4WEH82HM3XF/10CW110N9K4\n"
"H-4WEH82HE3XF/10CG60NS2DKL\n"
"H-4WEH82HE3XF/U\n"
"H-4WEH82HD3XF/10CG60NS2DKL\n"
"H-4WEH82HE3X/10CG24N9SK4\n"
"H-4WEH82HM3XF/10CG24N9S\n"
"H-4WEH82HD3X/OF10CG220N9K4\n"
"H-4WEH82HE3XF/10CW230N9TDKL\n"
"H-4WEH82HE3XF/10CG24NSDZ/13SO6\n"
"H-4WEH82HE3XF/10CG24N9SDL\n"
"H-4WEH82HE3X/10CG24N9ESDKL/B10D2\n"
"H-4WEH82HE3X/10CG24N9Z5L\n"
"H-4WEH82HE3X/10CG24N9K4\n"
"H-4WEH82HC3XF/10CG24N9K4\n"
"H-4WEH82HJ3XF/10CW110N9DAL/V\n"
"H-4WEH82HJ3X/10CG24N9S2K4\n"
"H-4WEH82HE3XF/10CG24N9SK4/13\n"
"H-4WEH82HE3X/10CG24N9SZ5L\n"
"H-4WEH82HC3XF/10CG24N9S/13\n"
"H-4WEH82HE3X/16AG24NS2Z5L/13SO35\n"
"H-4WEH82HE3X/10CG24NSDZL\n"
"H-4WEH82HE3XF/10CG24N9S/13\n"
"H-4WEH82HJ3X/10CG24NSDZL\n"
"H-4WEH82HD3XF/OF10EG220N9SK4\n"
"H-4WEH82HD3XF/10CG24N9S2K4/42B10\n"
"H-4WEH82HE3XF/10CG24N9K4\n"
"H-4WEH82HE3XF/10CG24NDLSO847\n"
"H-4WEH82HD3XF/10CG24N9K4\n"
"H-4WEH82HD3XF/OF10CG220N9SK4\n"
"H-4WH82HG3XF/\n"
"H-4WEH82HF3XF/10CW220N9S2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")