using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\+ ).*?(?= 23/24)";
string input = @"Fischer TRANSALP 86 CTI + TOUR CLASSIC ST BRAKE 92 23/24 162 modrá
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}