re = /(?<=\+ ).*?(?= 23\/24)/mi
str = 'Fischer TRANSALP 86 CTI + TOUR CLASSIC ST BRAKE 92 23/24 162 modrá
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end