package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"|DECLARE[^]+?Outbound| AS[^]+?DISPLAY NAME|\.\.| ON[^]+?;`)
var str = `DECLARE ENTITY FOLDER "Статистика Outbound".."XW_RTM_AGENT_D" AS "XW_RTM_AGENT_D" ENTITY "Statistical Outbound"."XW_RTM_AGENT_D"
FOLDER ATTRIBUTES (
"Статистика Outbound".."XW_RTM_AGENT_D"."U_CONTACT_CENTER",
"Статистика Outbound".."XW_RTM_AGENT_D"."U_MR",
"Статистика Outbound".."XW_RTM_AGENT_D"."U_GROUP_NAME",
"Статистика Outbound".."XW_RTM_AGENT_D"."U_NAME",
"Статистика Outbound".."XW_RTM_AGENT_D"."U_LOGIN",
"Статистика Outbound".."XW_RTM_AGENT_D"."U_CTI_PIN",
"Статистика Outbound".."XW_RTM_AGENT_D"."U_ACTIVE_POS_TYPE" )
DISPLAY NAME "Агенты" ON
DESCRIPTION {Для корректной работы в отчет с использованием таблицы "Агенты" можно включать поля из таблиц "Предложение", "Признаки", "Абонент", "Взаимодействие" и "Показатели" и нельзя включать поля из таблиц "Предложение (агрегир)" и "Показатели(агрегир)".}
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_CONTACT_CENTER" AS "U_CONTACT_CENTER" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_CONTACT_CENTER"
DISPLAY NAME "Контактный центр агента" ON
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_GROUP_NAME" AS "U_GROUP_NAME" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_GROUP_NAME"
DISPLAY NAME "Группа агента" ON
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_LOGIN" AS "U_LOGIN" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_LOGIN"
DISPLAY NAME "Логин агента Siebel" ON
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_MR" AS "U_MR" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_MR"
DISPLAY NAME "МР агента" ON
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_NAME" AS "U_NAME" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_NAME"
DISPLAY NAME "ФИО агента" ON
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_ACTIVE_POS_TYPE" AS "U_ACTIVE_POS_TYPE" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_ACTIVE_POS_TYPE"
DISPLAY NAME "Тип должности агента" ON
PRIVILEGES ( READ);
DECLARE FOLDER ATTRIBUTE "Статистика Outbound".."XW_RTM_AGENT_D"."U_CTI_PIN" AS "U_CTI_PIN" LOGICAL ATTRIBUTE "Statistical Outbound"."XW_RTM_AGENT_D"."U_CTI_PIN"
DISPLAY NAME "Логин агента Genesys" ON
PRIVILEGES ( READ);
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}