import re
regex = re.compile(r"\"|DECLARE[^]+?Outbound| AS[^]+?DISPLAY NAME|\.\.| ON[^]+?;", flags=re.MULTILINE)
test_str = ("DECLARE ENTITY FOLDER \"Статистика Outbound\"..\"XW_RTM_AGENT_D\" AS \"XW_RTM_AGENT_D\" ENTITY \"Statistical Outbound\".\"XW_RTM_AGENT_D\"\n"
" FOLDER ATTRIBUTES (\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_CONTACT_CENTER\",\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_MR\",\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_GROUP_NAME\",\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_NAME\",\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_LOGIN\",\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_CTI_PIN\",\n"
" \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_ACTIVE_POS_TYPE\" )\n"
" DISPLAY NAME \"Агенты\" ON \n"
" DESCRIPTION {Для корректной работы в отчет с использованием таблицы \"Агенты\" можно включать поля из таблиц \"Предложение\", \"Признаки\", \"Абонент\", \"Взаимодействие\" и \"Показатели\" и нельзя включать поля из таблиц \"Предложение (агрегир)\" и \"Показатели(агрегир)\".} \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_CONTACT_CENTER\" AS \"U_CONTACT_CENTER\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_CONTACT_CENTER\"\n"
" DISPLAY NAME \"Контактный центр агента\" ON \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_GROUP_NAME\" AS \"U_GROUP_NAME\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_GROUP_NAME\"\n"
" DISPLAY NAME \"Группа агента\" ON \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_LOGIN\" AS \"U_LOGIN\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_LOGIN\"\n"
" DISPLAY NAME \"Логин агента Siebel\" ON \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_MR\" AS \"U_MR\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_MR\"\n"
" DISPLAY NAME \"МР агента\" ON \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_NAME\" AS \"U_NAME\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_NAME\"\n"
" DISPLAY NAME \"ФИО агента\" ON \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_ACTIVE_POS_TYPE\" AS \"U_ACTIVE_POS_TYPE\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_ACTIVE_POS_TYPE\"\n"
" DISPLAY NAME \"Тип должности агента\" ON \n"
" PRIVILEGES ( READ);\n"
"DECLARE FOLDER ATTRIBUTE \"Статистика Outbound\"..\"XW_RTM_AGENT_D\".\"U_CTI_PIN\" AS \"U_CTI_PIN\" LOGICAL ATTRIBUTE \"Statistical Outbound\".\"XW_RTM_AGENT_D\".\"U_CTI_PIN\"\n"
" DISPLAY NAME \"Логин агента Genesys\" ON \n"
" PRIVILEGES ( READ);\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)