import re
regex = re.compile(r"\b(\w+)\b\s*-.*\s*(?=\1)")
test_str = ("Showder Klub - Showder Klub 26. évad 6. rész\n"
"Szerelem van a levegőben - Szerelem van a levegőben 61. rész\n"
"XXI. század - XXI. század – Az energiafüggőség és következményei (2022-06-13)\n"
"A fagy birodalma - Egy év a jégtáblán - 2. rész")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)