import Foundation
let pattern = #"\b(\w+)\b\s*-.*\s*(?=\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Showder Klub - Showder Klub 26. évad 6. rész
Szerelem van a levegőben - Szerelem van a levegőben 61. rész
XXI. század - XXI. század – Az energiafüggőség és következményei (2022-06-13)
A fagy birodalma - Egy év a jégtáblán - 2. rész
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)