re = /get(?:(?!get|66).)*?on/
str = 'get your kicks on Route 66
get your 66 kicks on Route
get your 56 kicks and get more kicks on Route'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end