import Foundation
let pattern = #"get(?:(?!get|66).)*?on"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
get your kicks on Route 66
get your 66 kicks on Route
get your 56 kicks and get more kicks on Route
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)