package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)as (\w+)`)
var str = `"Select s.BOOK_ID as bookID,s.first_name as firstName, s.last_name as lastName , b.book_name as bookName , b.price as price FROM STUDENTS s JOIN BOOKS b ON b.ID = s.BOOK_ID";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}