re = /as (\w+)/m
str = '"Select s.BOOK_ID as bookID,s.first_name as firstName, s.last_name as lastName , b.book_name as bookName , b.price as price FROM STUDENTS s JOIN BOOKS b ON b.ID = s.BOOK_ID";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end