package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64})\.kst$`)
var str = `hugepoopy.kst
buy@hugepoopy.kst
buy_many@hugepoopy.kst
buy@many@hugepoopy.kst
buy.many@hugepoopy.kst
hugepoopy.tst
huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}