re = /^(?:([a-z0-9-_]{1,32})@)?([a-z0-9]{1,64})\.kst$/mi
str = 'hugepoopy.kst
buy@hugepoopy.kst
buy_many@hugepoopy.kst
buy@many@hugepoopy.kst
buy.many@hugepoopy.kst
hugepoopy.tst
huuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuuugepoopy.kst'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end