using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\r\n]*myMethod((?:(?!myMethod).)*?)somethingelse";
string input = @"private myMethod
do something
private myMethod
do somethingelse";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}