$re = '/[^\r\n]*myMethod((?:(?!myMethod).)*?)somethingelse/s';
$str = 'private myMethod
do something
private myMethod
do somethingelse';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);