using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{(?>[^{}]|(?R))*}";
string input = @"{{Institution Name 1} and {Institution name 2}} and {Institution name 3} and {Institution and institution name 4}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}