$re = '/{(?>[^{}]|(?R))*}/m';
$str = '{{Institution Name 1} and {Institution name 2}} and {Institution name 3} and {Institution and institution name 4}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);