using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img( src=\"".*?\"")?( alt=\"".*?\"")?( height=\"".*?\"")?( width=\"".*?\"")?(\/|\ \/)?>";
string input = @" <img src=""smiley.gif"" alt=""Smiley face"" height=""42"" width=""42"">
<img src=""smiley.gif"" alt=""Smiley face"" height=""42"" width=""42""/>
<img src=""smiley.gif"" alt=""Smiley face"" height=""42"" width=""42"" />
<img src=""smiley.gif"" alt=""Smiley face"" height=""42"">
<img src=""smiley.gif"" width=""42"">
<img src=""smiley.gif"" alt=""Smiley face"" height=""42"" width=""42""> ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}