$re = '/<img( src=\".*?\")?( alt=\".*?\")?( height=\".*?\")?( width=\".*?\")?(\/|\ \/)?>/';
$str = ' <img src="smiley.gif" alt="Smiley face" height="42" width="42">
<img src="smiley.gif" alt="Smiley face" height="42" width="42"/>
<img src="smiley.gif" alt="Smiley face" height="42" width="42" />
<img src="smiley.gif" alt="Smiley face" height="42">
<img src="smiley.gif" width="42">
<img src="smiley.gif" alt="Smiley face" height="42" width="42"> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);