re = /(?<=How\s\w{4}\s).+|(?<=How\s\w{3}\s).+/m
str = 'How fast is the car moving?
How far do you drive to work every day?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end