const regex = /(\<script rel=\"gallery\" type=\"application\/json\">)([\s\S]*)(\<\/script\>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\<script rel=\\"gallery\\" type=\\"application\\\/json\\">)([\\s\\S]*)(\\<\\\/script\\>)', 'gm')
const str = `RegExr was created by gskinner.com.
<script rel="gallery" type="application/json">
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
</script>
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community and view patterns you create or favorite in My Patterns.
<script rel="gallery" type="application/json">
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
</script>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}