$re = '/(\<script rel=\"gallery\" type=\"application\/json\">)([\s\S]*)(\<\/script\>)/m';
$str = 'RegExr was created by gskinner.com.
<script rel="gallery" type="application/json">
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
</script>
The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community and view patterns you create or favorite in My Patterns.
<script rel="gallery" type="application/json">
Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & JavaScript flavors of RegEx are supported. Validate your expression with Tests mode.
</script>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);