package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([0-8]?[0-9]|90)°(\s[0-5]?[0-9]')?(\s[0-5]?[0-9](,[0-9]+)?")?$`)
var str = `57° 1' 50,031"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}