re = /^([0-8]?[0-9]|90)°(\s[0-5]?[0-9]')?(\s[0-5]?[0-9](,[0-9]+)?")?$/
str = '57° 1\' 50,031"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end