using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\n\s*|^\s*)\*\s";
string input = @"* Bla-bla
**Hello world!***
* 1)dsjdf
* vfd
*";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}