$re = '/(\n\s*|^\s*)\*\s/';
$str = '* Bla-bla
**Hello world!***
* 1)dsjdf
* vfd
*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);