using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<b>(.*?)<\/b>(.*?)(?=<b>|$)";
string input = @"<b>Title1:</b><br/><b>Title2:</b> Value1<br/><b>Title3:</b> Value2<br/><b>Title4:</b> Value3<br/>Value4<b>Title5:</b> Value5<br/>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}