re = /<b>(.*?)<\/b>(.*?)(?=<b>|$)/m
str = '<b>Title1:</b><br/><b>Title2:</b> Value1<br/><b>Title3:</b> Value2<br/><b>Title4:</b> Value3<br/>Value4<b>Title5:</b> Value5<br/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end