package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([[:alpha:]]+)(\s+[[:alpha:]])?$`)
var str = `John Smith A
John Smith An`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}