$re = '/([[:alpha:]]+)(\s+[[:alpha:]])?$/m';
$str = 'John Smith A
John Smith An';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);