import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Koord\\.\\sWGS-[EW]\\s:\\s\\d+\\.\\d+[\\r\\n]Koord\\.\\sWGS-[NS]\\s:\\s\\d+\\.\\d+";
final String string = "Koord. WGS-E : 9.8247876439\n"
+ "Koord. WGS-N : 49.5694479485\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}