re = /Koord\.\sWGS-(?P<direction>[EN])\s:\s(?P<coordinate1>\d+\.\d+)[\r\n]Koord\.\sWGS-[EN]\s:\s(?P<coordinate2>\d+\.\d+)/i
str = 'Koord. WGS-E : 9.8247876439
Koord. WGS-N : 49.5694479485
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end