$re = '/^.*?(?<!\S)(\S+)0(?!\S)(?:.*?(?<!\S)\1\d+(?!\S)){3}.*$/m';
$str = '123|456|...|789 I am a long string with substring0 and substring1 also substring2 something more and end with substring3
123|456|...|789 I am a long string with abcd0 and abcd1 also abcd2 something more and end with abcd3
123|456|...|789 I am a long string with substring0 and substring1 also substring2 something more and end with <removed>
123|456|...|789 I am a long string with abcd0 and abcd1 also abcd2 something more and end with <removed>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);