# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?(?<!\S)(\S+)0(?!\S)(?:.*?(?<!\S)\1\d+(?!\S)){3}.*$"
test_str = ("123|456|...|789 I am a long string with substring0 and substring1 also substring2 something more and end with substring3\n\n"
"123|456|...|789 I am a long string with abcd0 and abcd1 also abcd2 something more and end with abcd3\n\n"
"123|456|...|789 I am a long string with substring0 and substring1 also substring2 something more and end with <removed>\n\n"
"123|456|...|789 I am a long string with abcd0 and abcd1 also abcd2 something more and end with <removed>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.