const regex = /^(?=.*(?<!\S)foo@(?!\S).*)(?!.*(?<!\S)_bar#(?!\S).*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*(?<!\\S)foo@(?!\\S).*)(?!.*(?<!\\S)_bar#(?!\\S).*).*', 'gm')
const str = `foo1 _bar% baz5
foo@ _bar% baz4
foo@ _bar# baz4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}