$re = '/^(?=.*(?<!\S)foo@(?!\S).*)(?!.*(?<!\S)_bar#(?!\S).*).*/m';
$str = 'foo1 _bar% baz5
foo@ _bar% baz4
foo@ _bar# baz4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);