$re = '/(?<=\[)[^\]]+(?=\])/mi';
$str = 'I much prefer [kraken shell] to [fight through the pain] but [chain frost] is my favourite not a fan of []';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;