#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(?<=Order Number\n\n)\d{5}"
Local $sString = "Order Number" & @CRLF & _
"" & @CRLF & _
"25485" & @CRLF & _
"" & @CRLF & _
"Order Number" & @CRLF & _
"" & @CRLF & _
"25485"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")