$re = '/(?<=Order Number\n\n)\d{5}/is';
$str = 'Order Number
25485
Order Number
25485';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);