re = /(?<=>).*(?><)/m
str = '<h1 class="card-title-view__title" itemprop="name">муниципальный район Кобяйский улус</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end