#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?=" & @CRLF & _
" [ ]{0,8}? \d{1,9} " & @CRLF & _
" ( .* ) $ # (1)" & @CRLF & _
")" & @CRLF & _
"[ \d]{9} " & @CRLF & _
"(?= \1 $ )" & @CRLF & _
""
Local $sString = "examples of valid strings" & @CRLF & _
"" & @CRLF & _
"123456789" & @CRLF & _
"kfasdf 3456789asdf" & @CRLF & _
"a 1" & @CRLF & _
"" & @CRLF & _
"and examples of invalid strings" & @CRLF & _
"" & @CRLF & _
"12345 789" & @CRLF & _
"1 9" & @CRLF & _
"a 678a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")