import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=\n"
+ " [ ]{0,8}? \\d{1,9} \n"
+ " ( .* ) $ # (1)\n"
+ ")\n"
+ "[ \\d]{9} \n"
+ "(?= \\1 $ )\n";
final String string = "examples of valid strings\n\n"
+ "123456789\n"
+ "kfasdf 3456789asdf\n"
+ "a 1\n\n"
+ "and examples of invalid strings\n\n"
+ "12345 789\n"
+ "1 9\n"
+ "a 678a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}