import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\.\\#]?[a-z]+[\\s?>+~\\s?[a-z]+]?)|([\\{:\\};])|([a-z0-9]+)";
final String string = ".box {\n"
+ " background: red;\n"
+ " color: white;\n"
+ "}\n"
+ "div > span {\n\n"
+ "}\n\n"
+ "#p+span{\n"
+ " display:none;\n"
+ "}\n\n"
+ "tr ~td{\n"
+ " opacity:1;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}