#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!cat|\?).)+$"
Local $sString = "https://site.ru/?a=1" & @CRLF & _
"https://site.ru/cat1.html" & @CRLF & _
"https://site.ru/cat1/" & @CRLF & _
"https://site.ru/test" & @CRLF & _
"чтобы были выбраны только те строки, в которых нет знака вопроса и слова "cat"? "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")