use strict;
my $str = 'foo [https://www.example.com/link1](https://www.example.com/link2) data
bar https://www.example.com/link3?test[0]=val data data
xyz https://www.example.com/link4] test foo
https://www.example.com/link5';
my $regex = qr~\bhttps?://[^][()\s]*(?:\[\d+][^][\s]*)*~imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}